Using moonbeam xcm app, i transfered ksm to moonriver. I never recieved my ksm on moonriver

Here are the links to the 2 extrinsics because i tried it twice:

You can see that the xcm tx’s were constructed properly, as far as i can tell. But go down and examine the events. The xcmpallet(Attempted) event shows that the outcome was incomplete and that is has the property UNROUTABLE, which ive never seen before.

I did this all through the cross chain app which ive used countless times

I don’t know what happened but now my KSM is missing.

Any help would be appreciated.

hey, I tagged the DevRel team on Discord. I don’t think it makes sense to post the same message across multiple channels. so, for now, it’s better to wait for a response from the DevRel team on Discord

1 Like

Hey @Degen_Lennon :wave:

Thanks for getting in touch!

I tested the xcm transfer and debugged the outcome.
You’re right. The token transfer does not work anymore.

At Kusama block 20465806 roughly 10 hours ago the new runtime version 1.0.0 was enacted, which sadly - once again - broke the existing XCM integrations :frowning:

Rest assured that no funds are lost as they arrived on the parachains sovereign account.

Please be patient until devsDoSomething :pray:


Alright then! Thanks for the help. Yes I can rest easy now lol

1 Like

StateOfTheFuck can be tracked over here at Kusama side: XCM issue on Kusama · Issue #2238 · paritytech/polkadot-sdk · GitHub

1 Like


Getting back here. The issues has been identified. It is a Kusama problem but I’ll propose a fix to the Moonriver OpenGov Tech Committee so that this can be solved swiftly and not wait for the fix on Kusama.

I’ve tested the patch on Chopsticks and it works.


:tada: cross-linking the hotfix here [Proposal MRXX] Hotfix for Kusama Fails to Convert XCM from V3 -> V2


Tokens stuck in parachain bridge when transmitted from the Kusama network to the Moonriver (xcKSM)

hey Fasder, I tagged you today on Discord. check it out here: Discord

here’s a fix:

1 Like